import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^[.]+)([.])([^_.]+)_";
final String string = "[BillingFunctions.requestGprsTariff]\n"
+ "[BillingFunctions.requestGprsTariff]\n"
+ "[BillingFunctions.requestGprsTariff]\n"
+ "[BillingFunctions.requestSmsTariff]\n"
+ "[BillingFunctions.requestSmsTariff]\n"
+ "[BillingFunctions.requestSmsTariff]]\n"
+ "[BillingFunctions.requestVoiceTariff]\n"
+ "[BillingFunctions.requestVoiceTariff]\n"
+ "[BillingFunctions.requestVoiceTariff]\n"
+ "[GprsGxService.onStart]\n"
+ "[GprsGxService.onStart]\n"
+ "[GprsGxService.onStart]\n"
+ "[GprsGxService.onStart_ACCOUNT_NOT_FOUND]\n"
+ "[GprsGxService.onStart_ACCOUNT_NOT_FOUND]\n"
+ "[GprsGxService.onStart_ACCOUNT_NOT_FOUND]\n"
+ "[GprsGxService.onStart_CARD_ACTIVATED_IN_PROGRESS]\n"
+ "[GprsGxService.onStart_CARD_ACTIVATED_IN_PROGRESS]\n"
+ "[GprsGxService.onStart_CARD_ACTIVATED_IN_PROGRESS]\n"
+ "[GprsGxService.onStart_CARD_NOT_FOUND]\n"
+ "[GprsGxService.onStart_CARD_NOT_FOUND]\n"
+ "[GprsGxService.onStart_CARD_NOT_FOUND]\n"
+ "[GprsGxService.onStart_FAKE_NUMBER]\n"
+ "[GprsGxService.onStart_FAKE_NUMBER]\n"
+ "[GprsGxService.onStart_FAKE_NUMBER]\n"
+ "[GprsGxService.onStart_IMEI_NOT_MATCH_SPECIFIED]\n"
+ "[GprsGxService.onStart_IMEI_NOT_MATCH_SPECIFIED]\n"
+ "[GprsGxService.onStart_IMEI_NOT_MATCH_SPECIFIED]\n"
+ "[GprsGxService.onStart_INTERNAL_ERROR]\n"
+ "[GprsGxService.onStart_INTERNAL_ERROR]\n"
+ "[GprsGxService.onStart_INTERNAL_ERROR]\n"
+ "[GprsGxService.onStart_NO_MONEY]\n"
+ "[GprsGxService.onStart_NO_MONEY]\n"
+ "[GprsGxService.onStart_NO_MONEY]\n"
+ "[GprsGxService.onStart_OBJECT_BUSY]\n"
+ "[GprsGxService.onStart_OBJECT_BUSY]\n"
+ "[GprsGxService.onStart_OBJECT_BUSY]\n"
+ "[GprsGxService.onStart_OK]\n"
+ "[GprsGxService.onStart_OK]\n"
+ "[GprsGxService.onStart_OK]\n"
+ "[GprsGxService.onStart_SERVER_OVERLOADED]\n"
+ "[GprsGxService.onStart_SERVER_OVERLOADED]\n"
+ "[GprsGxService.onStart_SERVER_OVERLOADED]\n"
+ "[GprsGxService.onStart_SERVICE_IS_BLOCKED]\n"
+ "[GprsGxService.onStart_SERVICE_IS_BLOCKED]\n"
+ "[GprsGxService.onStart_SERVICE_IS_BLOCKED]\n"
+ "[GprsGxService.onStart_TARIFF_NOT_FOUND]\n"
+ "[GprsGxService.onStart_TARIFF_NOT_FOUND]\n"
+ "[GprsGxService.onStart_TARIFF_NOT_FOUND]\n"
+ "[GprsGxService.onStart_UNSUITABLE_CARD_STATE]\n"
+ "[GprsGxService.onStart_UNSUITABLE_CARD_STATE]\n"
+ "[GprsGxService.onStart_UNSUITABLE_CARD_STATE]\n"
+ "[GprsGxService.onStop]\n"
+ "[GprsGxService.onStop]\n"
+ "[GprsGxService.onStop]\n"
+ "[GprsGxService.onStop_OK]\n"
+ "[GprsGxService.onStop_OK]\n"
+ "[GprsGxService.onStop_OK]\n"
+ "[GprsGxService.onStop_SERVER_OVERLOADED]\n"
+ "[GprsGxService.onStop_SERVER_OVERLOADED]\n"
+ "[GprsGxService.onStop_SERVER_OVERLOADED]\n"
+ "[GprsGxService.onUpdate]\n"
+ "[GprsGxService.onUpdate]\n"
+ "[GprsGxService.onUpdate]\n"
+ "[GprsGxService.onUpdate_ACCESS_DENIED]\n"
+ "[GprsGxService.onUpdate_ACCESS_DENIED]\n"
+ "[GprsGxService.onUpdate_ACCESS_DENIED]\n"
+ "[GprsGxService.onUpdate_FORCED_BREAK_SESSION]\n"
+ "[GprsGxService.onUpdate_FORCED_BREAK_SESSION]\n"
+ "[GprsGxService.onUpdate_FORCED_BREAK_SESSION]\n"
+ "[GprsGxService.onUpdate_NO_MONEY]\n"
+ "[GprsGxService.onUpdate_NO_MONEY]\n"
+ "[GprsGxService.onUpdate_NO_MONEY]\n"
+ "[GprsGxService.onUpdate_OK]\n"
+ "[GprsGxService.onUpdate_OK]\n"
+ "[GprsGxService.onUpdate_OK]\n"
+ "[GprsGxService.onUpdate_SERVER_OVERLOADED]\n"
+ "[GprsGxService.onUpdate_SERVER_OVERLOADED]\n"
+ "[GprsGxService.onUpdate_SERVER_OVERLOADED]\n"
+ "[GprsGxService.onUpdate_SERVICE_IS_BLOCKED]\n"
+ "[GprsGxService.onUpdate_SERVICE_IS_BLOCKED]\n"
+ "[GprsGxService.onUpdate_SERVICE_IS_BLOCKED]\n"
+ "[GprsGxSession]\n"
+ "[GprsGxSession]\n"
+ "[GprsGxSession]\n"
+ "[GprsGyService.onStart]\n"
+ "[GprsGyService.onStart]\n"
+ "[GprsGyService.onStart]\n"
+ "[GprsGyService.onStart_ACCESS_DENIED]\n"
+ "[GprsGyService.onStart_ACCESS_DENIED]\n"
+ "[GprsGyService.onStart_ACCESS_DENIED]\n"
+ "[GprsGyService.onStart_CARD_NOT_FOUND]\n"
+ "[GprsGyService.onStart_CARD_NOT_FOUND]\n"
+ "[GprsGyService.onStart_CARD_NOT_FOUND]\n"
+ "[GprsGyService.onStart_GX_SESSION_NOT_FOUND]\n"
+ "[GprsGyService.onStart_GX_SESSION_NOT_FOUND]\n"
+ "[GprsGyService.onStart_GX_SESSION_NOT_FOUND]\n"
+ "[GprsGyService.onStart_INTERNAL_ERROR]\n"
+ "[GprsGyService.onStart_INTERNAL_ERROR]\n"
+ "[GprsGyService.onStart_INTERNAL_ERROR]\n"
+ "[GprsGyService.onStart_INVALID_TARIFF_CONFIGURATION]\n"
+ "[GprsGyService.onStart_INVALID_TARIFF_CONFIGURATION]\n"
+ "[GprsGyService.onStart_INVALID_TARIFF_CONFIGURATION]\n"
+ "[GprsGyService.onStart_NO_MONEY]\n"
+ "[GprsGyService.onStart_NO_MONEY]\n"
+ "[GprsGyService.onStart_NO_MONEY]\n"
+ "[GprsGyService.onStart_OBJECT_BUSY]\n"
+ "[GprsGyService.onStart_OBJECT_BUSY]\n"
+ "[GprsGyService.onStart_OBJECT_BUSY]\n"
+ "[GprsGyService.onStart_OK]\n"
+ "[GprsGyService.onStart_OK]\n"
+ "[GprsGyService.onStart_OK]\n"
+ "[GprsGyService.onStart_SERVER_OVERLOADED]\n"
+ "[GprsGyService.onStart_SERVER_OVERLOADED]\n"
+ "[GprsGyService.onStart_SERVER_OVERLOADED]\n"
+ "[GprsGyService.onStart_SERVICE_IS_BLOCKED]\n"
+ "[GprsGyService.onStart_SERVICE_IS_BLOCKED]\n"
+ "[GprsGyService.onStart_SERVICE_IS_BLOCKED]\n"
+ "[GprsGyService.onStart_SESSION_ALREADY_EXISTS]\n"
+ "[GprsGyService.onStart_SESSION_ALREADY_EXISTS]\n"
+ "[GprsGyService.onStart_SESSION_ALREADY_EXISTS]\n"
+ "[GprsGyService.onStop]\n"
+ "[GprsGyService.onStop]\n"
+ "[GprsGyService.onStop]\n"
+ "[GprsGyService.onStop_INTERNAL_ERROR]\n"
+ "[GprsGyService.onStop_INTERNAL_ERROR]\n"
+ "[GprsGyService.onStop_INTERNAL_ERROR]\n"
+ "[GprsGyService.onStop_OK]\n"
+ "[GprsGyService.onStop_OK]\n"
+ "[GprsGyService.onStop_OK]\n"
+ "[GprsGyService.onStop_SERVER_OVERLOADED]\n"
+ "[GprsGyService.onStop_SERVER_OVERLOADED]\n"
+ "[GprsGyService.onStop_SERVER_OVERLOADED]\n"
+ "[GprsGyService.onUpdate]\n"
+ "[GprsGyService.onUpdate]\n"
+ "[GprsGyService.onUpdate]\n"
+ "[GprsGyService.onUpdate_ACCESS_DENIED]\n"
+ "[GprsGyService.onUpdate_ACCESS_DENIED]\n"
+ "[GprsGyService.onUpdate_ACCESS_DENIED]\n"
+ "[GprsGyService.onUpdate_INTERNAL_ERROR]\n"
+ "[GprsGyService.onUpdate_INTERNAL_ERROR]\n"
+ "[GprsGyService.onUpdate_INTERNAL_ERROR]\n"
+ "[GprsGyService.onUpdate_INVALID_TARIFF_CONFIGURATION]\n"
+ "[GprsGyService.onUpdate_INVALID_TARIFF_CONFIGURATION]\n"
+ "[GprsGyService.onUpdate_INVALID_TARIFF_CONFIGURATION]\n"
+ "[GprsGyService.onUpdate_NO_MONEY]\n"
+ "[GprsGyService.onUpdate_NO_MONEY]\n"
+ "[GprsGyService.onUpdate_NO_MONEY]\n"
+ "[GprsGyService.onUpdate_OBJECT_BUSY]\n"
+ "[GprsGyService.onUpdate_OBJECT_BUSY]\n"
+ "[GprsGyService.onUpdate_OBJECT_BUSY]\n"
+ "[GprsGyService.onUpdate_OK]\n"
+ "[GprsGyService.onUpdate_OK]\n"
+ "[GprsGyService.onUpdate_OK]\n"
+ "[GprsGyService.onUpdate_SERVER_OVERLOADED]\n"
+ "[GprsGyService.onUpdate_SERVER_OVERLOADED]\n"
+ "[GprsGyService.onUpdate_SERVER_OVERLOADED]\n"
+ "[GprsGyService.onUpdate_SERVICE_IS_BLOCKED]\n"
+ "[GprsGyService.onUpdate_SERVICE_IS_BLOCKED]\n"
+ "[GprsGyService.onUpdate_SERVICE_IS_BLOCKED]\n"
+ "[GprsGyService.onUpdate_SESSION_NOT_FOUND]\n"
+ "[GprsGyService.onUpdate_SESSION_NOT_FOUND]\n"
+ "[GprsGyService.onUpdate_SESSION_NOT_FOUND]\n"
+ "[GprsGySession]\n"
+ "[GprsGySession]\n"
+ "[GprsGySession]\n"
+ "[Queue]\n"
+ "[Queue]\n"
+ "[Queue]\n"
+ "[SmsService.onCommit]\n"
+ "[SmsService.onCommit]\n"
+ "[SmsService.onCommit]\n"
+ "[SmsService.onCommit_OK]\n"
+ "[SmsService.onCommit_OK]\n"
+ "[SmsService.onCommit_OK]\n"
+ "[SmsService.onCommit_SERVER_OVERLOADED]\n"
+ "[SmsService.onCommit_SERVER_OVERLOADED]\n"
+ "[SmsService.onCommit_SERVER_OVERLOADED]\n"
+ "[SmsService.onRequest]\n"
+ "[SmsService.onRequest]\n"
+ "[SmsService.onRequest]\n"
+ "[SmsService.onRequest_CARD_ACTIVATED_IN_PROGRESS]\n"
+ "[SmsService.onRequest_CARD_ACTIVATED_IN_PROGRESS]\n"
+ "[SmsService.onRequest_CARD_ACTIVATED_IN_PROGRESS]\n"
+ "[SmsService.onRequest_CARD_NOT_FOUND]\n"
+ "[SmsService.onRequest_CARD_NOT_FOUND]\n"
+ "[SmsService.onRequest_CARD_NOT_FOUND]\n"
+ "[SmsService.onRequest_IMEI_NOT_MATCH_SPECIFIED]\n"
+ "[SmsService.onRequest_IMEI_NOT_MATCH_SPECIFIED]\n"
+ "[SmsService.onRequest_IMEI_NOT_MATCH_SPECIFIED]\n"
+ "[SmsService.onRequest_NO_MONEY]\n"
+ "[SmsService.onRequest_NO_MONEY]\n"
+ "[SmsService.onRequest_NO_MONEY]\n"
+ "[SmsService.onRequest_OK]\n"
+ "[SmsService.onRequest_OK]\n"
+ "[SmsService.onRequest_OK]\n"
+ "[SmsService.onRequest_SERVER_OVERLOADED]\n"
+ "[SmsService.onRequest_SERVER_OVERLOADED]\n"
+ "[SmsService.onRequest_SERVER_OVERLOADED]\n"
+ "[SmsService.onRequest_SERVICE_IS_BLOCKED]\n"
+ "[SmsService.onRequest_SERVICE_IS_BLOCKED]\n"
+ "[SmsService.onRequest_SERVICE_IS_BLOCKED]\n"
+ "[SmsService.onRequest_TARIFF_NOT_FOUND]\n"
+ "[SmsService.onRequest_TARIFF_NOT_FOUND]\n"
+ "[SmsService.onRequest_TARIFF_NOT_FOUND]\n"
+ "[SmsSession]\n"
+ "[SmsSession]\n"
+ "[SmsSession]\n"
+ "[VoiceService.onStart]\n"
+ "[VoiceService.onStart]\n"
+ "[VoiceService.onStart]\n"
+ "[VoiceService.onStart_CARD_ACTIVATED_IN_PROGRESS]\n"
+ "[VoiceService.onStart_CARD_ACTIVATED_IN_PROGRESS]\n"
+ "[VoiceService.onStart_CARD_ACTIVATED_IN_PROGRESS]\n"
+ "[VoiceService.onStart_NO_MONEY]\n"
+ "[VoiceService.onStart_NO_MONEY]\n"
+ "[VoiceService.onStart_NO_MONEY]\n"
+ "[VoiceService.onStart_OBJECT_BUSY]\n"
+ "[VoiceService.onStart_OBJECT_BUSY]\n"
+ "[VoiceService.onStart_OBJECT_BUSY]\n"
+ "[VoiceService.onStart_OK]\n"
+ "[VoiceService.onStart_OK]\n"
+ "[VoiceService.onStart_OK]\n"
+ "[VoiceService.onStart_SERVER_OVERLOADED]\n"
+ "[VoiceService.onStart_SERVER_OVERLOADED]\n"
+ "[VoiceService.onStart_SERVER_OVERLOADED]\n"
+ "[VoiceService.onStart_SERVICE_IS_BLOCKED]\n"
+ "[VoiceService.onStart_SERVICE_IS_BLOCKED]\n"
+ "[VoiceService.onStart_SERVICE_IS_BLOCKED]\n"
+ "[VoiceService.onStart_TARIFF_NOT_FOUND]\n"
+ "[VoiceService.onStart_TARIFF_NOT_FOUND]\n"
+ "[VoiceService.onStart_TARIFF_NOT_FOUND]\n"
+ "[VoiceService.onStart_UNSUITABLE_CARD_STATE]\n"
+ "[VoiceService.onStart_UNSUITABLE_CARD_STATE]\n"
+ "[VoiceService.onStart_UNSUITABLE_CARD_STATE]\n"
+ "[VoiceService.onStop]\n"
+ "[VoiceService.onStop]\n"
+ "[VoiceService.onStop]\n"
+ "[VoiceService.onStop_OK]\n"
+ "[VoiceService.onStop_OK]\n"
+ "[VoiceService.onStop_OK]\n"
+ "[VoiceService.onStop_SERVER_OVERLOADED]\n"
+ "[VoiceService.onStop_SERVER_OVERLOADED]\n"
+ "[VoiceService.onStop_SERVER_OVERLOADED]\n"
+ "[VoiceService.onUpdate]\n"
+ "[VoiceService.onUpdate]\n"
+ "[VoiceService.onUpdate]\n"
+ "[VoiceService.onUpdate_OK]\n"
+ "[VoiceService.onUpdate_OK]\n"
+ "[VoiceService.onUpdate_OK]\n"
+ "[VoiceService.onUpdate_SERVER_OVERLOADED]\n"
+ "[VoiceService.onUpdate_SERVER_OVERLOADED]\n"
+ "[VoiceService.onUpdate_SERVER_OVERLOADED]\n"
+ "[VoiceSession]\n"
+ "[VoiceSession]\n"
+ "[VoiceSession]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}