package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(mirror|reflect|serve|adapt)(\s*\w+\s*\W*\s*)*?(population|client|customer|stakeholder|market|society|culture|consumer|end-user)`)
var str = `mirror banana banannas populatio`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}