import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(mirror|reflect|serve|adapt)(\\s*\\w+\\s*\\W*\\s*)*?(population|client|customer|stakeholder|market|society|culture|consumer|end-user)";
final String string = "mirror banana banannas populatio";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}