re = /(mirror|reflect|serve|adapt)(\s*\w+\s*\W*\s*)*?(population|client|customer|stakeholder|market|society|culture|consumer|end-user)/m
str = 'mirror banana banannas populatio'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end