package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z ]*(?:-[A-Za-z]{0,3})?$`)
var str = `A
An
Any
Any
Any w
Any wo
Any wor
Any word
Any words
Any words -
Any words -A
Any words -AJ
Any words -AJW
Any words -AJWa
Any words -AJWab
Any words -AJWabc
-
-A
-AJ
-AJW
-AJW-
-AJW-A
-AJW-AJ
-AJW-AJW
And not Anywords-anywords-AJW
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}