const regex = /^[A-Za-z ]*(?:-[A-Za-z]{0,3})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Za-z ]*(?:-[A-Za-z]{0,3})?$', 'gm')
const str = `A
An
Any
Any
Any w
Any wo
Any wor
Any word
Any words
Any words -
Any words -A
Any words -AJ
Any words -AJW
Any words -AJWa
Any words -AJWab
Any words -AJWabc
-
-A
-AJ
-AJW
-AJW-
-AJW-A
-AJW-AJ
-AJW-AJW
And not Anywords-anywords-AJW
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}