$re = '/^[A-Za-z ]*(?:-[A-Za-z]{0,3})?$/mx';
$str = 'A
An
Any
Any
Any w
Any wo
Any wor
Any word
Any words
Any words -
Any words -A
Any words -AJ
Any words -AJW
Any words -AJWa
Any words -AJWab
Any words -AJWabc
-
-A
-AJ
-AJW
-AJW-
-AJW-A
-AJW-AJ
-AJW-AJW
And not Anywords-anywords-AJW
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);