const regex = /(\G(?!^)(?:[^}\n\w]+(?:o[fn]|in))*[^}\n\w]+|Title\s*=\s*\{)(\w)(\w*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\G(?!^)(?:[^}\\n\\w]+(?:o[fn]|in))*[^}\\n\\w]+|Title\\s*=\\s*\\{)(\\w)(\\w*)', 'gm')
const str = `...
Title = {Direct synthesis of antimicrobial coatings based on tailored bi-elemental nanoparticles},
journal={APL Mat.},
...`;
const subst = `$1\U$2\E$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);