$re = '/(\G(?!^)(?:[^}\n\w]+(?:o[fn]|in))*[^}\n\w]+|Title\s*=\s*\{)(\w)(\w*)/m';
$str = '...
Title = {Direct synthesis of antimicrobial coatings based on tailored bi-elemental nanoparticles},
journal={APL Mat.},
...';
$subst = "$1\U$2\E$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;