# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\G(?!^)(?:[^}\n\w]+(?:o[fn]|in))*[^}\n\w]+|Title\s*=\s*\{)(\w)(\w*)"
test_str = ("...\n"
"Title = {Direct synthesis of antimicrobial coatings based on tailored bi-elemental nanoparticles},\n"
"journal={APL Mat.},\n"
"...")
subst = "$1\\U$2\\E$3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.