using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Location\[gps (-?\d+(?:\.\d+)?),(-?\d+(?:\.\d+)?)";
string input = @"location: Location[gps 39.549497,-120.328997 hAcc=20 et=+44m40s745ms alt=0.0 vel=0.0 bear=0.0 vAcc=??? sAcc=??? bAcc=??? {Bundle[mParcelledData.dataSize=96]}]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}