const regex = /Location\[gps (-?\d+(?:\.\d+)?),(-?\d+(?:\.\d+)?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Location\\[gps (-?\\d+(?:\\.\\d+)?),(-?\\d+(?:\\.\\d+)?)', 'gm')
const str = `location: Location[gps 39.549497,-120.328997 hAcc=20 et=+44m40s745ms alt=0.0 vel=0.0 bear=0.0 vAcc=??? sAcc=??? bAcc=??? {Bundle[mParcelledData.dataSize=96]}]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}