#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[tag(?:=(["']?)(.+)\1)?\](.*?)\[\/tag\]"
Local $sString = "[tag=foo]foo[/tag]foo[/tag]" & @CRLF & _
"[tag="foo"]foo[/tag]foo[/tag]" & @CRLF & _
"[tag='foo']foo[/tag]foo[/tag]" & @CRLF & _
"[tag]sdfo[/tag][/tag]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")