$re = '/\[tag(?:=(["\']?)(.+)\1)?\](.*?)\[\/tag\]/m';
$str = '[tag=foo]foo[/tag]foo[/tag]
[tag="foo"]foo[/tag]foo[/tag]
[tag=\'foo\']foo[/tag]foo[/tag]
[tag]sdfo[/tag][/tag]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);