re = /\[tag(?:=(["']?)(.+)\1)?\](.*?)\[\/tag\]/m
str = '[tag=foo]foo[/tag]foo[/tag]
[tag="foo"]foo[/tag]foo[/tag]
[tag=\'foo\']foo[/tag]foo[/tag]
[tag]sdfo[/tag][/tag]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end