package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mis)(?<FirstPart>(?:<div>.*?){4}).*(?<SecondPart>(?:<\/div>.*?){4})`)
var str = `<!DOCTYPE html>
<html>
<head>
</head>
<body>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</body>
</html>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}