$re = '/(?<FirstPart>(?:<div>.*?){4}).*(?<SecondPart>(?:<\/div>.*?){4})/mis';
$str = '<!DOCTYPE html>
<html>
<head>
</head>
<body>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</body>
</html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);