package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*)(?:\.\s).*`)
var str = `Some AB, Author C, Names DEF. The title string. T journal name 2018;10:560-564`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}