$re = '/^(.*)(?:\.\s).*/m';
$str = 'Some AB, Author C, Names DEF. The title string. T journal name 2018;10:560-564';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);