re = /^(.*)(?:\.\s).*/m
str = 'Some AB, Author C, Names DEF. The title string. T journal name 2018;10:560-564'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end