package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?:https?|ftp|file):\/\/)?([\w-]{1,32}\.[\w-]{1,32})[^\s@]*$`)
var str = `госуслуги.рф`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}