$re = '/((?:https?|ftp|file):\/\/)?([\w-]{1,32}\.[\w-]{1,32})[^\s@]*$/m';
$str = 'госуслуги.рф';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);