re = /((?:https?|ftp|file):\/\/)?([\w-]{1,32}\.[\w-]{1,32})[^\s@]*$/m
str = 'госуслуги.рф'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end