package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[a-z]+((\d)|([A-Z0-9][a-z0-9]+))*([A-Z])?`)
var str = `xmlHttpRequest
newCustomerId
innerStopwatch
supportsIpv6OnIos
youTubeImporter
youtubeImporter
affine3D
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}