re = /[a-z]+((\d)|([A-Z0-9][a-z0-9]+))*([A-Z])?/
str = 'xmlHttpRequest
newCustomerId
innerStopwatch
supportsIpv6OnIos
youTubeImporter
youtubeImporter
affine3D
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end