#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(uddi:)?(.{8}-.{4}-.{4}-.{4}-.{12})"
Local $sString = "fc8c266b-c8f2-11e5-9d5f-9e9121fad333" & @CRLF & _
"93d3df4b-c8f3-11e5-9d5f-d3f525e3d96f" & @CRLF & _
"uddi:f0bb22eb-c8f3-11e5-9d5f-ab76fa0fe1ef" & @CRLF & _
"uddi:a6f8027b-c8f5-11e5-9d5f-be39eae1ed33" & @CRLF & _
"uddi:1ee0417b-c8f2-11e5-9d5f-d5eb774576ea" & @CRLF & _
"uddi:0e87b9f3-de46-11e6-a117-e9c8b22fac1e" & @CRLF & _
"uddi:eca57383-de46-11e6-a117-9c0349538667" & @CRLF & _
"2a759413-de47-11e6-a117-f6cb2452465f" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Put" & @CRLF & _
" ProDS" & @CRLF & _
"" & @CRLF & _
"NBSWLFRTService" & @CRLF & _
"NEMEventProcessorService" & @CRLF & _
"Nationwide_DiscoveryApp" & @CRLF & _
"PendingTransactionsOrchestrationService" & @CRLF & _
"UnclearedTransactions-1-0" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""MtsiEnquiry service offers " & @CRLF & _
"methods for the retrieval of information about a customer’s account"" & @CRLF & _
""MtsiEnquiry service offers " & @CRLF & _
"methods for the retrieval of information about a customer’s account"" & @CRLF & _
""** Needs Checking as it was missing from CentraSite **" & @CRLF & _
"MtsiEnquiry service offers " & @CRLF & _
"methods for the retrieval of information about a customer’s account"" & @CRLF & _
""** Needs Checking as it was missing from CentraSite **" & @CRLF & _
"This contains functionality not in 8.3 and needs to be merged back into the next iteration (i.e. any planned 8.4 version)" & @CRLF & _
"MtsiEnquiry service offers " & @CRLF & _
"methods for the retrieval of information about a customer’s account"" & @CRLF & _
""MtsiEnquiry service offers " & @CRLF & _
"methods for the retrieval of information about a customer’s account with details like maindetails,additional details,offers ,etc."" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")