import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(uddi:)?(.{8}-.{4}-.{4}-.{4}-.{12})";
final String string = "fc8c266b-c8f2-11e5-9d5f-9e9121fad333\n"
+ "93d3df4b-c8f3-11e5-9d5f-d3f525e3d96f\n"
+ "uddi:f0bb22eb-c8f3-11e5-9d5f-ab76fa0fe1ef\n"
+ "uddi:a6f8027b-c8f5-11e5-9d5f-be39eae1ed33\n"
+ "uddi:1ee0417b-c8f2-11e5-9d5f-d5eb774576ea\n"
+ "uddi:0e87b9f3-de46-11e6-a117-e9c8b22fac1e\n"
+ "uddi:eca57383-de46-11e6-a117-9c0349538667\n"
+ "2a759413-de47-11e6-a117-f6cb2452465f\n\n\n\n"
+ "Put\n"
+ " ProDS\n\n"
+ "NBSWLFRTService\n"
+ "NEMEventProcessorService\n"
+ "Nationwide_DiscoveryApp\n"
+ "PendingTransactionsOrchestrationService\n"
+ "UnclearedTransactions-1-0\n\n\n\n"
+ "\"MtsiEnquiry service offers \n"
+ "methods for the retrieval of information about a customer’s account\"\n"
+ "\"MtsiEnquiry service offers \n"
+ "methods for the retrieval of information about a customer’s account\"\n"
+ "\"** Needs Checking as it was missing from CentraSite **\n"
+ "MtsiEnquiry service offers \n"
+ "methods for the retrieval of information about a customer’s account\"\n"
+ "\"** Needs Checking as it was missing from CentraSite **\n"
+ "This contains functionality not in 8.3 and needs to be merged back into the next iteration (i.e. any planned 8.4 version)\n"
+ "MtsiEnquiry service offers \n"
+ "methods for the retrieval of information about a customer’s account\"\n"
+ "\"MtsiEnquiry service offers \n"
+ "methods for the retrieval of information about a customer’s account with details like maindetails,additional details,offers ,etc.\"\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}