package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(uddi:)?(.{8}-.{4}-.{4}-.{4}-.{12})`)
var str = `fc8c266b-c8f2-11e5-9d5f-9e9121fad333
93d3df4b-c8f3-11e5-9d5f-d3f525e3d96f
uddi:f0bb22eb-c8f3-11e5-9d5f-ab76fa0fe1ef
uddi:a6f8027b-c8f5-11e5-9d5f-be39eae1ed33
uddi:1ee0417b-c8f2-11e5-9d5f-d5eb774576ea
uddi:0e87b9f3-de46-11e6-a117-e9c8b22fac1e
uddi:eca57383-de46-11e6-a117-9c0349538667
2a759413-de47-11e6-a117-f6cb2452465f
Put
ProDS
NBSWLFRTService
NEMEventProcessorService
Nationwide_DiscoveryApp
PendingTransactionsOrchestrationService
UnclearedTransactions-1-0
"MtsiEnquiry service offers
methods for the retrieval of information about a customer’s account"
"MtsiEnquiry service offers
methods for the retrieval of information about a customer’s account"
"** Needs Checking as it was missing from CentraSite **
MtsiEnquiry service offers
methods for the retrieval of information about a customer’s account"
"** Needs Checking as it was missing from CentraSite **
This contains functionality not in 8.3 and needs to be merged back into the next iteration (i.e. any planned 8.4 version)
MtsiEnquiry service offers
methods for the retrieval of information about a customer’s account"
"MtsiEnquiry service offers
methods for the retrieval of information about a customer’s account with details like maindetails,additional details,offers ,etc."
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}