#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(#define\s*CANIF_AR_RELEASE_REVISION_VERSION\s*\().+?(\).*?)"
Local $sString = "#define CANIF_AR_RELEASE_MAJOR_VERSION (FFFU)" & @CRLF & _
"#define CANIF_AR_RELEASE_MINOR_VERSION (1XFFUU)" & @CRLF & _
"#define CANIF_AR_RELEASE_REVISION_VERSION (2X000FFFU)" & @CRLF & _
"#define TEST_McalModule_CanTp_ID (70U) /* 0x46 */"
Local $sSubst = "\g<1>3U\g<2>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)