import re
regex = re.compile(r"(#define\s*CANIF_AR_RELEASE_REVISION_VERSION\s*\().+?(\).*?)", flags=re.MULTILINE)
test_str = ("#define CANIF_AR_RELEASE_MAJOR_VERSION (FFFU)\n"
"#define CANIF_AR_RELEASE_MINOR_VERSION (1XFFUU)\n"
"#define CANIF_AR_RELEASE_REVISION_VERSION (2X000FFFU)\n"
"#define TEST_McalModule_CanTp_ID (70U) /* 0x46 */")
subst = "\\g<1>3U\\g<2>"
result = regex.sub(subst, test_str)
if result:
print(result)