const regex = new RegExp('(#define\\s*CANIF_AR_RELEASE_REVISION_VERSION\\s*\\().+?(\\).*?)', 'gm')
const str = `#define CANIF_AR_RELEASE_MAJOR_VERSION (FFFU)
#define CANIF_AR_RELEASE_MINOR_VERSION (1XFFUU)
#define CANIF_AR_RELEASE_REVISION_VERSION (2X000FFFU)
#define TEST_McalModule_CanTp_ID (70U) /* 0x46 */`;
const subst = `\g<1>3U\g<2>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);