# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"google.*cpc"
test_str = ("google.fr\n"
"google.co.jp\n"
"google.co.kr\n"
"google.com.my\n"
"google.ae\n"
"accounts.google.com.sg\n"
"accounts.google.co.id\n"
"google/cpc/[google][cpc][house][sale]\n"
"google/cpc/[google][cpc][condo][sale]\n"
"google/cpc/[google][cpc][house][sale][กรุงเทพ]\n"
"google/cpc/[google][cpc][condo][rent]\n"
"google/cpc/[google][cpc][land][sale]\n"
"google/cpc/[google][cpc][townhouse][sale]\n"
"google/cpc/[google][cpc][house][rent]\n"
"google/cpc/[google][cpc][apartment][rent]\n"
"google/cpc/[google][cpc][land][sale][กรุงเทพ]\n"
"google/cpc/[google][cpc][condo][sale][กรุงเทพ]\n"
"google/cpc/[google][cpc][commercial][sale]\n"
"google/cpc/[google][cpc][house][sale][ปทุมธานี]\n"
"google/cpc/[google][cpc][commercial][rent]\n"
"google/cpc/[google][cpc][land][sale][ปทุมธานี]\n"
"google/cpc/[google][cpc][house][sale][ชลบุรี]\n"
"google/cpc/[google][cpc][condo][sale][bangkok]\n"
"google/cpc/[google][cpc][townhouse][rent]\n"
"google/cpc/[google][cpc][house][sale][เชียงใหม่]\n"
"google/cpc/[google][cpc][townhouse][rent][กรุงเทพ]\n"
"google/cpc/[google][cpc][land][sale][ชลบุรี]")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.