import Foundation
let pattern = #"google.*cpc"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
google.fr
google.co.jp
google.co.kr
google.com.my
google.ae
accounts.google.com.sg
accounts.google.co.id
google/cpc/[google][cpc][house][sale]
google/cpc/[google][cpc][condo][sale]
google/cpc/[google][cpc][house][sale][กรุงเทพ]
google/cpc/[google][cpc][condo][rent]
google/cpc/[google][cpc][land][sale]
google/cpc/[google][cpc][townhouse][sale]
google/cpc/[google][cpc][house][rent]
google/cpc/[google][cpc][apartment][rent]
google/cpc/[google][cpc][land][sale][กรุงเทพ]
google/cpc/[google][cpc][condo][sale][กรุงเทพ]
google/cpc/[google][cpc][commercial][sale]
google/cpc/[google][cpc][house][sale][ปทุมธานี]
google/cpc/[google][cpc][commercial][rent]
google/cpc/[google][cpc][land][sale][ปทุมธานี]
google/cpc/[google][cpc][house][sale][ชลบุรี]
google/cpc/[google][cpc][condo][sale][bangkok]
google/cpc/[google][cpc][townhouse][rent]
google/cpc/[google][cpc][house][sale][เชียงใหม่]
google/cpc/[google][cpc][townhouse][rent][กรุงเทพ]
google/cpc/[google][cpc][land][sale][ชลบุรี]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)