re = /google.*cpc/m
str = 'google.fr
google.co.jp
google.co.kr
google.com.my
google.ae
accounts.google.com.sg
accounts.google.co.id
google/cpc/[google][cpc][house][sale]
google/cpc/[google][cpc][condo][sale]
google/cpc/[google][cpc][house][sale][กรุงเทพ]
google/cpc/[google][cpc][condo][rent]
google/cpc/[google][cpc][land][sale]
google/cpc/[google][cpc][townhouse][sale]
google/cpc/[google][cpc][house][rent]
google/cpc/[google][cpc][apartment][rent]
google/cpc/[google][cpc][land][sale][กรุงเทพ]
google/cpc/[google][cpc][condo][sale][กรุงเทพ]
google/cpc/[google][cpc][commercial][sale]
google/cpc/[google][cpc][house][sale][ปทุมธานี]
google/cpc/[google][cpc][commercial][rent]
google/cpc/[google][cpc][land][sale][ปทุมธานี]
google/cpc/[google][cpc][house][sale][ชลบุรี]
google/cpc/[google][cpc][condo][sale][bangkok]
google/cpc/[google][cpc][townhouse][rent]
google/cpc/[google][cpc][house][sale][เชียงใหม่]
google/cpc/[google][cpc][townhouse][rent][กรุงเทพ]
google/cpc/[google][cpc][land][sale][ชลบุรี]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end