import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\/\\n]*\\/\\s*([^\\/\\n]*?)(?=\\s*(?:\\/|$))";
final String string = "Test1 / Test 2 / Test 3\n"
+ "Test1 / Test2\n"
+ "Test 1 / Test2 / Test3\n"
+ "Test 1 / Test 2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}