const regex = /^[^\/\n]*\/\s*([^\/\n]*?)(?=\s*(?:\/|$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\\/\\n]*\\\/\\s*([^\\\/\\n]*?)(?=\\s*(?:\\\/|$))', 'gm')
const str = `Test1 / Test 2 / Test 3
Test1 / Test2
Test 1 / Test2 / Test3
Test 1 / Test 2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}