using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Instagram(?!.+\<\/a\>)";
string input = @"<p>This is a test piece of text that contains the keywords in my array like <a>Photos</a>, C.V., CV, <a>Google</a>, <a>Github</a>, <a>Portfolio</a>, Instagram, <a>email</a> and Simon, ignoring the keywords if they're existing <a href=""#"">Simon links</a>.</p>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}