re = /Instagram(?!.+\<\/a\>)/m
str = '<p>This is a test piece of text that contains the keywords in my array like <a>Photos</a>, C.V., CV, <a>Google</a>, <a>Github</a>, <a>Portfolio</a>, Instagram, <a>email</a> and Simon, ignoring the keywords if they\'re existing <a href="#">Simon links</a>.</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end