import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Instagram(?!.+\\<\\/a\\>)";
final String string = "<p>This is a test piece of text that contains the keywords in my array like <a>Photos</a>, C.V., CV, <a>Google</a>, <a>Github</a>, <a>Portfolio</a>, Instagram, <a>email</a> and Simon, ignoring the keywords if they're existing <a href=\"#\">Simon links</a>.</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}