using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*\Qrepresented\E).*(*SKIP)|[^\d\n]+";
string substitution = @"";
string input = @"Understanding Marked Sub-Expressions and Captures
fTextf
Are the iterator ranges that are captured by marked subexpressions as a regular expression gets matched Each marked disallow subexpression for beginsdisalloincludeends can result in more than one capture, if it is matched more than once This document explains how captures beginsinclude2ends and marked sub-expressions in Boost. Regex are represented and accessed. Tex t
Text Marked sub-expressions beginsinclude3ends Text rets terra
Every time a Perl regular expression contains a parenthesis group, it spits out an extra field, known as a marked sub-expression, for example the expression:";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}