import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\Qrepresented\\E).*(*SKIP)|[^\\d\\n]+";
final String string = "Understanding Marked Sub-Expressions and Captures\n\n"
+ "fTextf\n"
+ "Are the iterator ranges that are captured by marked subexpressions as a regular expression gets matched Each marked disallow subexpression for beginsdisalloincludeends can result in more than one capture, if it is matched more than once This document explains how captures beginsinclude2ends and marked sub-expressions in Boost. Regex are represented and accessed. Tex t\n\n"
+ "Text Marked sub-expressions beginsinclude3ends Text rets terra\n\n"
+ "Every time a Perl regular expression contains a parenthesis group, it spits out an extra field, known as a marked sub-expression, for example the expression:";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}