const regex = /^(?!.*\Qrepresented\E).*(*SKIP)|[^\d\n]+/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\Qrepresented\\E).*(*SKIP)|[^\\d\\n]+', 'mg')
const str = `Understanding Marked Sub-Expressions and Captures
fTextf
Are the iterator ranges that are captured by marked subexpressions as a regular expression gets matched Each marked disallow subexpression for beginsdisalloincludeends can result in more than one capture, if it is matched more than once This document explains how captures beginsinclude2ends and marked sub-expressions in Boost. Regex are represented and accessed. Tex t
Text Marked sub-expressions beginsinclude3ends Text rets terra
Every time a Perl regular expression contains a parenthesis group, it spits out an extra field, known as a marked sub-expression, for example the expression:`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);