using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|\s+)[^\s<>]+(?:\s+[^\s<>]+)*(?:\s+|$)";
string input = @"this simple the<b>html string</b> text test that<b>need</b>to<b>spl</b>it it too";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}