re = /(?:^|\s+)[^\s<>]+(?:\s+[^\s<>]+)*(?:\s+|$)/m
str = 'this simple the<b>html string</b> text test that<b>need</b>to<b>spl</b>it it too'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end