// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:^|\s+)[^\s<>]+(?:\s+[^\s<>]+)*(?:\s+|$)").unwrap();
let string = "this simple the<b>html string</b> text test that<b>need</b>to<b>spl</b>it it too";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}