using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"!\[readme-images\/([a-zA-Z0-9_.-\/]*)\].*$";
string substitution = @"<img src=""readme-images/$1"" width=""300""/>";
string input = @"screen123.css
screen-new-file.css
screen_new.js
screen new file.css
.......
no funny $#!&@$
screen/sf
Examples:



Code Example:
https://github.com/apollosolutions/retail-supergraph/blob/main/subgraphs/products/schema.graphql
# 1. GraphQL API for each microservice";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}