$re = '/!\[readme-images\/([a-zA-Z0-9_.-\/]*)\].*$/m';
$str = 'screen123.css
screen-new-file.css
screen_new.js
screen new file.css
.......
no funny $#!&@$
screen/sf
Examples:



Code Example:
https://github.com/apollosolutions/retail-supergraph/blob/main/subgraphs/products/schema.graphql
# 1. GraphQL API for each microservice';
$subst = "<img src=\"readme-images/$1\" width=\"300\"/>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;