package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Zip: (?P<state>.*)`)
var str = `Name: Test Smith
Email: test@test.com
Phone: 123-456-7890
City: Dallas
State: TX
Zip: 75201`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}