import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Zip: (?P<state>.*)";
final String string = "Name: Test Smith\n"
+ "Email: test@test.com\n"
+ "Phone: 123-456-7890\n"
+ "City: Dallas\n"
+ "State: TX\n"
+ "Zip: 75201";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}