const regex = new RegExp('Zip: (?P<state>.*)', 'gm')
const str = `Name: Test Smith
Email: test@test.com
Phone: 123-456-7890
City: Dallas
State: TX
Zip: 75201`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}